Ubuntu 16.04 less i PhpStorm

Możemy zainstalować less poprzez:
sudo apt install node-less
Jednak wtedy dostaniemy błędy: (node) util.print is deprecated. Use console.log instead.
Należy więc usunąć „less-node” -> sudo apt purge node-less i zainstalować poprzez „NPM”. Kolejne komendy będą wyglądały tak:
sudo apt install npm
sudo npm install -g less
sudo npm install -g clean-css
sudo ln -s /usr/bin/nodejs /usr/bin/node
sudo ln -s /usr/local/bin/lessc /usr/bin/lessc

W PhpStorm linię „Arguments” zmieniamy na: --clean-css="--s0" $FileName$
Dzięki przełącznikowi:
–clean-css – usuniemy wszystkie białe znaki i spora część kodu będzie w jednej linii
–s0 (to jest opcja dodatkowa do clean-css) usuniemy komentarze.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Proszę dokończyć równanie: * Time limit is exhausted. Please reload CAPTCHA.